S12004

Error Code

S12004

Error Message

The meta.log file was not found. Please contact technical support to check the online recovery process. RefId: S12004

Probable Causes

This error occurs when the meta.log file cannot be found during the reconstruction of metadata after the online recovery process. This may be because the file fails to be transferred due to network or logical issues, or because the file is not correctly written to disk.

Solutions

Contact DolphinDB technical support to examine the online recovery process with dolphindb.log and check if meta.log is successfully transferred. To be specific, look for log entries related to <Error> RemoteRun [dfsSaveChunkRemote] to identify the specific cause of the error.